Degraded Query Performance affecting all Particle customers

Incident Report for Particle Health

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 00:07 EDT

Monitoring

We believe we identified the issue and the system no longer has elevated latency. We will continue monitoring for the next few hours, but we expect the latency to be back to normal.
Posted Apr 01, 2026 - 00:47 EDT

Investigating

Network queries are currently taking longer to complete than what is typical. This is currently affecting all Particle customers as query complete notifications, transition alerts, and new encounter alerts will be delayed in processing and being sent.

We are actively investigating this.
Posted Mar 31, 2026 - 21:22 EDT
This incident affected: Particle Production API and Notification System (Webhooks).