Data Processing Delays for Workbench FLAT and FHIR

Incident Report for Particle Health

Resolved

This incident has been resolved.
Posted May 21, 2026 - 14:17 EDT

Monitoring

We found the issue and reprocessing has resumed. We are back to operational state though some lingering delays could still be happening. We are continuing to monitor the system.
Posted May 21, 2026 - 14:03 EDT

Investigating

We are currently investigating slowdown in data processing, this should affect Workbench FHIR and FLAT customers.
Posted May 21, 2026 - 13:48 EDT
This incident affected: Particle Production API.